Help

Important Support Links

Frequently Asked Questions

  • Who are you?
    Im Fhizban (Fhiz), Web-Developer and AddOn Developer for uMMORPG3d
  • What is NuCore?
    NuCore Guide
  • Why can’t I download NuCore?
    You must get verified first. This means you have to proof that you legally purchased the uMMORPG3d asset. You can get verified in the original uMMORPG3d discord channel, or by sending us a proof of purchase. We then add your eMail to the NuCore Download Butler where you can download all available versions of the NuCore.
  • How do I install your AddOns?
    Installation Guide
  • I bought the Whole Bundle, can you help?
    Please contact us via eMail or the Discord Support Server. Provide proof of purchase. We will create a account on our new store for you. Then you can download updated versions of the AddOns you already purchased.
  • I bought AddOns through another store, can you help?
    This only applies to my previous stores (shop.critical-hit.biz or my old critical-hit asset store listings). Please contact us via eMail or the Discord Support Server. Provide proof of purchase. We will create a account on our new store for you. Then you can download updated versions of the AddOns you already purchased.
  • I got the WholeBundle (or any other bundle) and now several of my downloads are missing!
    Re-purchase the WholeBundle using the coupon code you received. This will regenerate all download rights.
  • After importing several of the scripts attached to prefabs are missing!
    Check the line endings of your .cs files in Mono Develop. Some operating systems use a different line endings encoding.
  • Im using an older version of uMMORPG, can you help?
    No. My AddOns are compatible with the most recent uMMORPG version only. Please stay up to date to ensure best user experience.
  • Are your AddOns compatible with uMMORPG2d as well?
    No. And they won’t anytime soon (maybe in 2 years).
  • After importing, my project shows many red errors!
    Do you have both the NuCore and NuTools installed? Many AddOns require those two. Also make sure to delete your Scripting Define Symbols. Also make sure to read the general AddOn installation guidelines. Finally make sure all colliders (used frequently for zones) have the “Is Trigger” attribute checked.
  • I get a SyncVar limit reached error and my project does not compile!
    Please download HLPAPI Pro (developed by Vis), it fixes a lot of Unity UNET bugs and increases the amount of SyncVars: https://forum.unity3d.com/threads/unet-hlapi-pro-taking-unet-to-the-next-level.425437/